Author Topic: Unable to run VNL 2008.10 on Ubuntu 9.10  (Read 8190 times)

0 Members and 1 Guest are viewing this topic.

Offline Anders Blom

  • QuantumWise Staff
  • Supreme ATK Wizard
  • *****
  • Posts: 4972
  • Country: dk
  • Reputation: 78
    • View Profile
    • QuantumWise
Unable to run VNL 2008.10 on Ubuntu 9.10
« on: November 13, 2009, 13:07 »
After upgrading to Ubuntu 9.10, VNL 2008.10 will not start, because libg2c is missing. In earlier versions this library could just be installed from the Package Manager, but from 9.10 this is no longer possible.

The solution is to download the attached tar-file and manually install the required files in /usr/lib.

Installation instructions

1. Download and save the attachment in your home directory

2. Extract the tar-file:

Code: [Select]
cd $HOME
tar xzvf libg2c_32bit.tgz

The next step differs between 32/64-bit distros.

3: On 32-bit Ubuntu:
Code: [Select]
sudo mv libg2c.* /usr/lib

3: On 64-bit Ubuntu:
Code: [Select]
sudo mv libg2c.* /usr/lib32

After this, VNL 2008.10 should start.
« Last Edit: November 13, 2009, 13:09 by Anders Blom »

Offline quentin300

  • New ATK user
  • *
  • Posts: 1
  • Reputation: 0
    • View Profile
Re: Unable to run VNL 2008.10 on Ubuntu 9.10
« Reply #1 on: May 5, 2010, 13:04 »
I am having the same problem with another program called eigenstrat, which also needs lg2c and cannot compile (cannot find -lg2c). under ubuntu 9.10.

i followed your advice and copied the files to lib32. thanks for this help. however: same error message as before...

do you have any suggestion ? does ld look in lib32 automatically ?

I see that I have those libg2 libraries (not libg2c) in the usr/lib/ could they be any help ?

thank you,
 
quentin

Offline Anders Blom

  • QuantumWise Staff
  • Supreme ATK Wizard
  • *****
  • Posts: 4972
  • Country: dk
  • Reputation: 78
    • View Profile
    • QuantumWise
Re: Unable to run VNL 2008.10 on Ubuntu 9.10
« Reply #2 on: May 5, 2010, 13:46 »
Our posted solution is for getting VNL to run, not compile. There's a big difference, and it also matters very much if you have a 32- or 64-bit application. Seems you're on a 64-bit platform, but then you should also use 32-bit compilers if you want to use 32-bit libg2c. However, if this is the case, probably a better path for you is to install a real 64-bit g2c and compile with that.

Your 64-bit compiler will not look in lib32, for natural reasons :)

Beyond that, I can't help, we only offer support for our own software.
« Last Edit: May 5, 2010, 13:48 by Anders Blom »

Offline espinzong

  • New ATK user
  • *
  • Posts: 1
  • Reputation: 0
    • View Profile
Re: Unable to run VNL 2008.10 on Ubuntu 9.10
« Reply #3 on: September 18, 2010, 15:11 »
Thanks a lot Anders Bloom!!! I've been rumbling around with this for like a week!! For a next case, where did you find the package?

By the way, I have Ubuntu 10.04 and it was successful.